mightyoflower

“Page not found”: Troubleshooting permalink glitches

Posted: February 13th, 2012 | Author: | Filed under: random tech tips | Comments Off on “Page not found”: Troubleshooting permalink glitches

Problem:  You compose a new WordPress blog post.  As usual, when you click “Publish” you see the confirmation message “Post published” at the top of the “Edit Post” page.  However, when you click “View post” or visit your website to check the post, you get the error message “Page not found.”

(Possible) solution:  It could be a permalink glitch, one that is easily fixed, as I’ll explain below.

One of the sites that I manage has a custom setting for its permalinks.  The setting is:

/index.php/%postname%/

This setting gives each post that I create a permalink containing the title of the post, such as:

http://mysite.com/index.php/here-is-my-newest-post-with-its-catchy-title/

I found that blog titles containing certain punctuation — like an apostrophe S (‘s) messed the system up and caused these “page not found” errors to occur.

In my case, changing the permalink setting for the whole website was a very bad idea. I had already spread hundreds of links far and wide in promoting the content.  If I was to change the permalink setting, all of these links that had been shared with the website’s audience would now produce nothing more than dead pages.

The best and easiest solution is to simply deal with problematic posts’ permalinks on a case-by-case basis.

  1. Navigate to the “Edit Post” page for the troublesome post.
  2. Type in (or keep) whatever title you want for the post.
  3. Under the field where you typed in the title of the post, click on the “Change permalinks” button.
  4. Remove offending punctuation from the permalink.
  5. Update the post.

This worked for me — I hope it works for you, too.


Comments are closed.